fbpx

Failover de Link de Internet com MikroTik

Aqui estou colocando as configurações que mostrei no video no youtube.

Abraço Leonardo Vieira

/tool e-mail
set address=mail.contratoti.com.br [email protected] password=senhadoemail port=587 user=\
[email protected]

Crie as rotas sendo a principal e a secundaria com o comentário como exemplo abaixo. Lembre-se de mudar o email que esta no script

/ip route
add comment=principal distance=1 gateway=240.222.32.1
add check-gateway=ping comment=secundario distance=2 gateway=200.201.230.1
add distance=1 dst-address=8.8.4.4/32 gateway=200.201.230.1
add distance=1 dst-address=8.8.8.8/32 gateway=240.222.32.1

/tool netwatch
add down-script=”/ip route disable [find comment=\”principal\”]\r\
\n/log error \”O link do provedor 1 caiu\”\r\
\n/tool e-mail send [email protected] subject=\”link provedor1 caiu\”\r\
\n” host=8.8.8.8 up-script=”/ip route enable [find comment=\”principal\”]\r\
\n/tool e-mail send [email protected] subject=\”link provedor1 VOLTOU\””
add down-script=”/ip route disable [find comment=\”secundario\”]\r\
\n/log error \”O link do provedor 2 caiu\”\r\
\n /tool e-mail send to=\”[email protected]\” subject=\”link provedor2 caiu\”\r\
\n” host=8.8.4.4 up-script=”/ip route enable [find comment=\”secundario\”]\r\
\n /tool e-mail send to=\”[email protected]\” subject=\”link provedor2 VOLTOU\””

09/02/2021

3 responses on "Failover de Link de Internet com MikroTik"

  1. Seu escript ta errado, esta com aspas pra funcionar tive que trocar:/tool netwatch
    add down-script=”/ip route disable [find comment=\”principal\”]\r\
    \n/log error \”O link do provedor 1 caiu\”\r\
    \n/tool e-mail send [email protected] subject=\”link provedor1 caiu\”\r\
    \n” host=8.8.8.8 up-script=”/ip route enable [find comment=\”principal\”]\r\
    \n/tool e-mail send [email protected] subject=\”link provedor1 VOLTOU\””
    add down-script=”/ip route disable [find comment=\”secundario\”]\r\
    \n/log error \”O link do provedor 2 caiu\”\r\
    \n /tool e-mail send to=\”[email protected]\” subject=\”link provedor2 caiu\”\r\
    \n” host=8.8.4.4 up-script=”/ip route enable [find comment=\”secundario\”]\r\
    \n /tool e-mail send to=\”[email protected]\” subject=\”link provedor2 VOLTOU\””

    corrige pq vai que alguem não intende de mikrotik e faz errado

  2. O meu não funcionou nem com as aspas nem sem ela.

  3. Bem, aqui fiz o teste e funcionou, não tem nada de errado. Muito bem explicado o script.

Leave a Message

O seu endereço de e-mail não será publicado.

Desenvolvido por Contract TI