fbpx

No-IP no MikroTik

##############Configuracoes do Script##################
# Leonardo Vieira - youtube.com/leomikrotik


:local NOIPUser "SEULOGIN"
:local NOIPPass "SUASENHA"
:local NOIPDomain "seudominio.ddns.net"

###############################################

#Obtendo o IP
:global currentIP [/ip cloud get public-address]

:if ([:resolve $NOIPDomain] = $currentIP) do={
      #/tool fetch mode=http user=$NOIPUser password=$NOIPPass url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$NOIPDomain&myip=$currentIP" keep-result=no
	  /tool fetch mode=http url="http://$NOIPUser:[email protected]/nic/update?hostname=$NOIPDomain&myip=$currentIP" keep-result=no
      :log info "NO-IP Update: $NOIPDomain - $currentIP"
}

Infelizmente tenho um cliente que não tem Link dedicado e o IP Dinamico não chega na RB e sim em uma ONU a frente da RB que tem DMZ. Então usei o script acima pra pegar o IP publico e associar a um no-ip enquanto o cloud da MikroTik não funciona.

06/09/2021

2 responses on "No-IP no MikroTik"

  1. Muito obrigado pelo compartilhamento.

  2. SAULO ALVES OLIVEIRA MENEZES07/09/2021 at 07:41Responder

    Valeu professor, vou tentar.

Leave a Message

O seu endereço de e-mail não será publicado.

Desenvolvido por Contract TI